MeshCentral inaccessible from internet
Incident Report for Frodlenet
Resolved
This incident has been resolved.
Posted May 11, 2021 - 19:16 BST
Investigating
We are currently investigating this issue.
Posted May 11, 2021 - 16:37 BST
This incident affected: Titania (MeshCentral).